1. 首页
  2. 灯光观点

通达信明了主图指标公式



流通市值:FINANCE(40)/100000000;
MA5角度:ATAN((MA(close,5)/REF(MA(CLOSE,5),1)-1)*100)*180/3.142,NODRAW,COLOrrED;
A1:=REF(H,8)=HHV(H,2*8 1);
B1:=FILTER(A1,8);
c1:=BACKSET(B1,8 1);
d1:=FILTER(C1,8);{高点}
r11:=BACKSET(ISLAstBAR,BARSlast(D1) 1); S11:=R11REF(R11,1);
DRAWline(D1,H,S11,H,1),COLORBLUE;
A2:=REF(L,8)=LLV(L,2*8 1);
B2:=FILTER(A2,8);
C2:=BACKSET(B2,8 1);
D2:=FILTER(C2,8);{低点}
t11:=BACKSET(ISLASTBAR,BARSLAST(D2) 1); U11:=T11REF(T11,1);
DRAWLINE(D2,L,U11,L,1),COLORBLUE;
M:=INTPART(3*8/5);
A12:=REF(H,M)=HHV(H,2*M 1);
B12:=FILTER(A12,M);
C12:=BACKSET(B12,M 1);
D12:=FILTER(C12,M);{高点}
R112:=BACKSET(ISLASTBAR,BARSLAST(D12) 1); S112:=R112REF(R112,1);
DRAWLINE(D12,H,S112,H,1),COLORRED;
A22:=REF(L,M)=LLV(L,2*M 1);
B22:=FILTER(A22,M);
C22:=BACKSET(B22,M 1);
D22:=FILTER(C22,M);{低点}
T112:=BACKSET(ISLASTBAR,BARSLAST(D22) 1); U112:=T112REF(T112,1);
DRAWLINE(D22,L,U112,L,1),COLORRED;
VAR1111:=BACKSET(REF(high,2)=HHV(HIGH,5),3);
VAr2222:=croSS(VAR1111,0.9);
VAR3333:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
VAR4444:=CROSS(VAR3333,0.9);
压力:= REF(HIGH,BARSLAST(VAR2222));
stiCKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2222)),REF(HIGH,BARSLAST(VAR2222)),0.5,1),COLOREA91B5,LINETHICK3;
支撑:= REF(LOW,BARSLAST(VAR4444));
STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4444)),REF(LOW,BARSLAST(VAR4444)),0.5,1),COLOR00B4FF,LINETHICK3;
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
RRRSV:=sma(下档线,3,1);
KKK:=SMA(RRRSV,3,1);
ddd:=((3 * RRRSV) - (2 * KKK));
jj12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
RSV24:=SMA(JJ12,3,1);
K24:=SMA(RSV24,3,1);
D24:=((3 * RSV24) - (2 * K24));
压力2:=IF(CROSS(D24,DDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDD)))),COLORFFFFFF;
压力位:=IF(ISLASTBAR,压力2,DRAWNULL);
STICKLINE(ISLASTBAR ,压力位,压力位,120,0),LINETHICK4,COLORFFFFFF;
底部:=LLV(HIGH,30),COLOR00FF00;
底部位:=IF(ISLASTBAR,底部,DRAWNULL);
STICKLINE(ISLASTBAR ,底部位,底部位,100,0),LINETHICK4,COLOR00FF00;
AA05:=MA(C,5),COLOR0099CC;
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(ema((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:EMA((速度5-REF(速度5,1)),3),NODRAW;
Aa10:=MA(C,10);
AA20:=MA(C,20);BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
VAR11:=(AA20-AA30)REF((AA20-AA30),1)
AND AA20REF(AA20,1) AND AA30REF(AA30,1);
VAR22:=(AA30-AA20)REF((AA30-AA20),1) AND AA20REF(AA20,1) AND
AA30REF(AA30,1);
Bb30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB3030 AND BB1045 AND
CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)=1 AND
AA05REF(AA05,1) AND 三拾日乖离率REF(三拾日乖离率,1) AND
AA10REF(AA10,1)
AND 加速度5REF(加速度5,1) AND 速度5REF(速度5,1) ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)=1 AND (CAA30 OR OAA30) AND
AA05REF(AA05,1) AND 三拾日乖离率REF(三拾日乖离率,1) AND
AA10REF(AA10,1),10);
DRAWicoN(加仓 ,LOW*0.99,34);
TYP := (HIGH LOW CLOSE)/3;
cci1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,6));
差值1:=abs(REF(CCI1,1)-CCI1),LINETHICK0;
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;
CCI:=CCI1 CCI2 CCI3 CCI4 CCI5;
aaa:=(3*C H L O)/6;
VAR1:=(8*AAA 7*REF(AAA,1) 6*REF(AAA,2) 5*REF(AAA,3) 4*REF(AAA,4) 3*REF(AAA,5) 2*REF(AAA,6) REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5) HHV(VAR1,10) HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5) LLV(VAR1,10) LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5) HHV(VAR2,10) HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5) LLV(VAR3,10) LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2) LLV(VAR1,4) LLV(VAR1,6))/3;
短线:VAR1,COLORWHITE;
中线:VAR6,COLORYELLOW;
下跌:IF(VAR1=VAR6,VAR6, DRAWNULL),COLORGREEN;
TJ1:= CCI1差值4;
立桩量:=FILTER(TJ1,0);
TJ2:=IF(BARSLAST(立桩量)=1 ,1,IF(BARSLAST(立桩量)=2 ,1,
IF(BARSLAST(立桩量)=3 ,1,0)));
成立1:=TJ2;
条件成立1:=FILTER(成立1,5);
TJ11:= CCI1-差值4 ;
立桩量2:=FILTER(TJ11,0);
TJ22:=IF(BARSLAST(立桩量2)=1 AND CLOSEREF(HIGH,1),1,
IF(BARSLAST(立桩量2)=2 AND CLOSEREF(HIGH,2),1,
IF(BARSLAST(立桩量2)=3 AND CLOSEREF(HIGH,3),1,0)));
成立2:=TJ22;
条件成立2:=FILTER(成立2,5);
TJ111:=(ABS(CCI1)CCI AND ABS( 差值1) ABS(差值5))
OR (VOL=HHV(VOL,10) AND VOL2*REF(VOL,1) AND CLOSEVAR1);
立桩量3:=FILTER(TJ111,5);
TJ222:=IF(BARSLAST(立桩量3)=1 AND CLOSEREF(HIGH,1),1,IF(BARSLAST(立桩量3)=2 AND CLOSEREF(HIGH,2),1,IF(BARSLAST(立桩量3)=3 AND CLOSEREF(HIGH,3),1,0)));
突破3:=TJ222=1;
STICKLINE(CLOSE AND 下跌!= VAR6,REF(HIGH,BARSLAST(立桩量3)),
REF(HIGH,BARSLAST(立桩量3)),10,1),COLORCYAN;
STICKLINE(CLOSE AND 下跌!= VAR6,REF(LOW,BARSLAST(立桩量3)),
REF(LOW,BARSLAST(立桩量3)),10,1),COLORYELLOW;
TJ3:=IF(BARSLAST(立桩量3)=1 AND CLOSEREF(LOW,1),1,IF(BARSLAST(立桩量3)=2 AND CLOSEREF(LOW,2),1,IF(BARSLAST(立桩量3)=3 AND CLOSEREF(LOW,3),1,0)));
三天法则:=TJ3=1;
成立:=三天法则 AND 突破3;
条件成立:=FILTER(成立,5);
TJ31:=(VOL=HHV(VOL,10) AND VOL2*REF(VOL,1) AND CLOSEVAR1);
TJ32:=FILTER(TJ31,1);
IF(条件成立 AND 下跌!= VAR6 AND AA30=REF(AA30,1),H*1.03,DRAWNULL),CROSsdOT,LINETHICK6,COLORFF33FF;
IF(条件成立 AND 下跌!= VAR6 AND AA30=REF(AA30,1),H*1.03,DRAWNULL),POINtdOT,LINETHICK4,COLOR00CCFF;

本文内容来自互联网转载,不代表本人立场,若侵犯您的权益,请联系我们第一时间删除,谢谢!如若转载,请注明出处:http://www.bullgains.com/guandian/57b0e7e87c2065e994cb189b.html