1. 首页
  2. 新股推荐

通达信带F10资料的主图指标公式介绍

  m1:=5;

  M2:=10;

  m3:=20;

  M4:=30;

  m5:=60;

  M6:=120;

  M7:=250;

  M8:=500;

  N:=9;

  DRAWGBK(C》0,rgb(00,0,150),RGB(0,00,0),0,,0);

  利润同比:=strcatstRCAT(利润同比:,COn2STR(FINANCE(43),2)),%);

  收入同比:=STRCAT(STRCAT(收入同比:,CON2STR(FINANCE(44),2)),%);

  主营利润率:=STRCAT(STRCAT(主营利润率:,CON2STR(FINANCE(23)/FINANCE(20)*100,2)),%);

  所属地域:=STRCAT(所属地域:,DYBLocK);

  所属行业:=STRCAT(所属行业:,hyblock);

  所属概念:=STRCAT(所属概念:,GNBLOCK);

  所属风格:=STRCAT(所属风格:,FGBLOCK);

  主营业务:=STRCAT(主营业务:,EXTERnsTR(0,1));

  季报披露:=STRCAT(STRCAT(季报披露:,CON2STR(FINANCE(37),0)),季度);

  市值:=STRCAT(STRCAT( 流通市值: ,CON2STR((CAPITal/1000000)*C,2)),亿元);

  DRAWTEXT_FIX(1,0.00,0.01,0,利润同比),COLORMAGENTA;

  DRAWTEXT_FIX(1,0.11,0.01,0,收入同比),COLORMAGENTA;

  DRAWTEXT_FIX(1,0.22,0.01,0,主营利润率),COLORMAGENTA;

  DRAWTEXT_FIX(1,0.00,0.07,0,所属地域),COLOR0080FF;

  DRAWTEXT_FIX(1,0.22,0.07,0,市值),COLOR0080FF;

  DRAWTEXT_FIX(1,0.00,0.14,0,所属行业),COLORYELLOW;

  DRAWTEXT_FIX(1,0.00,0.42,0,所属概念),COLORYELLOW;

  DRAWTEXT_FIX(1,0.00,0.35,0,所属风格),COLORCYAN;

  DRAWTEXT_FIX(1,0.00,0.28,0,季报披露),COLORYELLOW;

  DRAWTEXT_FIX(1,0.11,0.07,0,流通A股:)COLOR0080FF;

  DRAWTEXT_FIX(1,0.15,0.07,0,STRCAT(CON2STR(CAPITAL/1000000,2),亿股))COLOR0080FF;

  DRAWTEXT_FIX(1,0.11,0.28,0,每股收益:)COLORYELLOW;

  DRAWTEXT_FIX(1,0.15,0.28,0,STRCAT(CON2STR(FINANCE(30)/FINANCE(1),2),元))COLORYELLOW;

  DRAWTEXT_FIX(1,0.11,0.14,0,每股净资产: 元)COLORYELLOW;

  DRAWTEXT_FIX(1,0.17,0.14,0,CON2STR(FINANCE(34),2))COLORYELLOW;

  DRAWTEXT_FIX(1,0.22,0.14,0,每股公积金: 元)COLORYELLOW;

  DRAWTEXT_FIX(1,0.28,0.14,0,CON2STR(FINANCE(18),2))COLORYELLOW;

  DRAWTEXT_FIX(1,0.11,0.21,0,每股未分配: 元)COLOrrED;

  DRAWTEXT_FIX(1,0.17,0.21,0,CON2STR(FINANCE(32),2))COLORRED;

  DRAWTEXT_FIX(1,0.22,0.21,0,经营现金流: 元)COLORRED;

  DRAWTEXT_FIX(1,0.28,0.21,0,CON2STR(FINANCE(25)/FINANCE(1),2))COLORRED;

  上市年数:=STRCAT(STRCAT(上市年数:,CON2STR(FINANCE(42)/365,2)),年);

  DRAWTEXT_FIX(1,0.00,0.21,0,上市年数),COLORCYAN;

  aaa1:=STRCAT(沪深总上涨家数:,CON2STR(DYNAINfo(60),0));

  AAA2:=STRCAT(沪深总下跌家数:,CON2STR(DYNAINFO(61),0));

  DRAWTEXT_FIX(1,0.35,0.28,0,AAA1),COLORRED;

  DRAWTEXT_FIX(1,0.47,0.28,0,AAA2),COLORGREEN;

  AAA3:=STRCAT(前日收盘:,CON2STR(DYNAINFO(3),2));

  AAa4:=STRCAT(现价:,CON2STR(DYNAINFO(7),2));

  DRAWTEXT_FIX(1,0.35,0.01,0,AAA3),COLORYELLOW;

  DRAWTEXT_FIX(1,0.47,0.01,0,AAA4),COLORYELLOW;

  AAA5:=STRCAT(成交金额:,CON2STR(DYNAINFO(10)/100000000,2));

  AAa6:=STRCAT(成交金额:,CON2STR(DYNAINFO(7)/100000000,2)),亿元;

  DRAWTEXT_FIX(1,0.35,0.07,0,AAA5),COLORYELLOW;

  DRAWTEXT_FIX(1,0.42,0.07,0,AAA6),COLORYELLOW;

  AAA7:=STRCAT(换手率:,CON2STR(DYNAINFO(37)*100,2));

  AAA8:=STRCAT(成交金额:,CON2STR(DYNAINFO(7)/100000000,2)),(%);

  DRAWTEXT_FIX(1,0.47,0.07,0,AAA7),COLORYELLOW;

  DRAWTEXT_FIX(1,0.52,0.07,0,AAA8),COLORYELLOW;

  MA5:MA(close,M1),COLORWHITE;

  ma10:MA(CLOSE,M2),COLORYELLOW;

  MA20:MA(CLOSE,M3),COLORMAGENTA;

  MA30:MA(CLOSE,M4),COLORGREEN;

  MA60:MA(CLOSE,M5),COLORLIGRAY;

  MA120:MA(CLOSE,M6),COLORCYAN;

  MA250:MA(CLOSE,M7),COLOR0080FF;

  Ma500:MA(CLOSE,M8),COLOR808000;

  NA:=BARSlast(YEAR!=REF(YEAR,1));

  NQT:=BACKSET(NA=0,2);

  NT:=BARSLAST(croSS(NQT=1,0.5));

  NC:=REF(REF(C,NT),1);

  年涨幅:(C-NC)/NC*100 NodRAW;

  DRAWTEXT_FIX(1,0.00,0.49,0,[主题投资]:)COLORMAGENTA;

  DRAWTEXT_FIX(1,0.04,0.49,0,EXTERNSTR(0,1))COLORMAGENTA;

  DRAWTEXT_FIX(1,0.00,0.56,0,[主营业务]:)COLORCYAN;

  DRAWTEXT_FIX(1,0.04,0.56,0,EXTERNSTR(0,2))COLORCYAN;

  {N:=9;}

  BC:=(H*0.382 L*0.618 O*0.382 C*0.618)/2;

  lj:=IF(INDEXC=C,BC,(BC AMOUNT/(V*100))/2);

  HT:=REF((HHV(LJ,N*0.691) HHV(LJ,N) HHV(LJ,N*1.309))/3,1);

  LT:=REF((LLV(LJ,N*0.691) LLV(LJ,N) LLV(LJ,N*1.309))/3,1);

  ZT:=(HT LT)/2,lineTHICK,COLORYELLOW;

  stiCKLINE(ISLASTBAR=1 AND LJ《ZT,HT,LT,N*8,0),COLORBLUE;

  STICKLINE(ISLASTBAR=1 AND LJ=ZT,HT,LT,N*8,0),COLORGRAY;

  STICKLINE(ISLASTBAR=1 AND LJ》ZT,HT,LT,N*8,1),COLOR6600FF;

  STICKLINE(ISLASTBAR=1,ZT,ZT,N*8,0),COLORYELLOW;

  箱顶:HT,LINethICK,COLORRED;

  箱底:LT,LINETHICK,COLORGREEN;

  箱中:ZT,LINETHICK,COLORYELLOW;

  {跌K线蓝色

  DRAWKLINE(high,OPEN,LOW,CLOSE);

  STICKLINE(O》=C,C,O,2.6,0),COLORFF0000;

  STICKLINE(O》=C,C,O,1.9,0),COLORFF3300;

  STICKLINE(O》=C,C,O,1.2,0),COLORFF6600;

  STICKLINE(O》=C,C,O,0.5,0),COLORFF9900;

  {涨K线

  STICKLINE(C》O,C,O,2.6,0),COLOR000088;

  STICKLINE(C》O,C,O,1.9,0),COLOR0000AA;

  STICKLINE(C》O,C,O,1.2,0),COLOR0000CC;

  STICKLINE(C》O,C,O,0.4,0),COLOR0000EE;}

  {下公式中K线跌为绿色}

  STICKLINE(C》O,H,L,0,0),COLOR7D7DFF;

  STICKLINE(C》O,C,O,0,0),COLOR7D7DFF;

  STICKLINE(C》O,C,O,3.1,0),COLOR1313FF;

  STICKLINE(C》O,C,O,2.4,0),COLOr2424FF;

  STICKLINE(C》O,C,O,2.0,0),COLOR2D2DFF;

  STICKLINE(C》O,C,O,1.6,0),COLOR4444FF;

  STICKLINE(C》O,C,O,1.2,0),COLOR5757FF;

  STICKLINE(C》O,C,O,0.6,0),COLOR6666FF;

  STICKLINE(C》O,C,O,0.1,0),COLOR7D7DFF;

  STICKLINE(C《O,H,L,0,0),COLORFF9900{COLORD0D000};

  STICKLINE(C《O,C,O,0,0),COLORFF5500{COLORD0D000};

  STICKLINE(C《O,C,O,3.1,0),COLORFF6600{COLOR8C8C00};

  STICKLINE(C《O,C,O,2.4,0),COLORFF7700{COLOR959500};

  STICKLINE(C《O,C,O,2.0,0),COLORFF8800{COLOR9F9F00};

  STICKLINE(C《O,C,O,1.6,0),COLORFF9900{COLORAAAA00};

  STICKLINE(C《O,C,O,1.2,0),COLORFFAA00{COLORB5B500};

  STICKLINE(C《O,C,O,0.6,0),COLORFfcC00{COLORBFBF00};

  STICKLINE(C《O,C,O,0.1,0),COLORFFFF00{COLORD0D000};

  {以下为涨停跌停都是紫色}

  涨幅限制:=IF(NAMELIKE(ST) OR NAMELIKE(*ST) OR NAMELIKE(SST) OR NAMELIKE(S*ST),105,110);{代表1.05和1.1}

  跌幅限制:=IF(NAMELIKE(ST) OR NAMELIKE(*ST) OR NAMELIKE(SST) OR NAMELIKE(S*ST),95,90);{代表0.95和0.9}

  涨停:=ROUND(CLOSE*100)》=ROUND(REF(CLOSE,1)*涨幅限制) AND CLOSE=HIGH;

  STICKLINE(涨停,C,O,3,0),COLORDD00DD{COLORFF00FF{COLOR9F5F9F};

  STICKLINE(涨停,C,O,2.5,0),COLORBB00BB{COLOR8E236B};

  STICKLINE(涨停,C,O,2,0),COLORFF00FF{COLOR8E236B};

  STICKLINE(涨停,C,O,1.3,0),COLORFF00FF{COLORFF6EC7};

  STICKLINE(涨停,C,O,1,0),COLORFF83FA;

  STICKLINE(涨停,C,O,0.2,0),COLORFABBFF{COLORMAGENTA};

  STICKLINE(涨停,H,L,0,0),COLORFF00FF{COLORMAGENTA};

  跌停:=ROUND(CLOSE*100)《=ROUND(REF(CLOSE,1)*跌幅限制 1) AND CLOSE=LOW;

  STICKLINE(跌停,O,C,3,0),COLOR9F5F9F;

  STICKLINE(跌停,O,C,2.5,0),COLOr115555{COLOR8E236B};

  STICKLINE(跌停,O,C,2,0),COLOR117777{COLOR8E236B};

  STICKLINE(跌停,O,C,1.5,0),COLOR119999{COLORFF6EC7};

  STICKLINE(跌停,O,C,1,0),COLOR11BBBB{COLORFF6EC7};

  STICKLINE(跌停,O,C,0.5,0),COLOR11dddD{COLORYELLOW};

  STICKLINE(跌停,L,H,0,0),COLOR44FFFF{COLORYELLOW};

  {下公式为连板假阴线}

  A:=EVERY(REF(C,1)/REF(C,2)》1.09,2) AND C》REF(C,1) AND C《O AND H/L》1.05;

  B:=BARSLAST(A);

  DRAWTEXT(A,C,--------------------------------------------)COLORYELLOW;

  DRAWTEXT(A,H,连板假阴)COLORYELLOW;

  DRAWicoN(CROSS(C,REF(H*1.03,B)) AND B《30,LOW,9);

  {涨跌停}

  涨停1:=C/REF(C,1)》1.09;

  STICKLINE(涨停1,OPEN,CLOSE,1.5,0),COLORYELLOW;

  跌停1:=REF(C,1)/C》1.09;

  STICKLINE(跌停1,OPEN,CLOSE,1.5,0),COLORWHITE;

  {以下为急拉急洗指标}

  A1:=EVERY(C《REF(C,1),3) AND EVERY(REF(C,3)/REF(C,4)》1.06,2) AND L》=REF(L,4);

  B1:=BARSLAST(A1);

  DRAWTEXT(A1,LOW,。..。..。..。..。..。..。..。..。..。..。..。..。..。..。..。..。..。..。..。..。..。..。..。..。..。.)COLORYELLOW;

  DRAWTEXT(A1,H,急拉急洗)COLORYELLOW;

  DRAWICON(CROSS(C,REF(H*1.03,B1)) AND C》O AND B1《60 AND LLV(L,B1)》REF(L,B1)*0.9,LOW,9);

  {DRAWICON(CROSS(C,REF(H*1.1,B)) AND C》O AND B《60 AND H=HHV(H,20) AND LLV(L,B)》REF(L,B)*0.9,LOW,9);};

  

本文内容来自互联网转载,不代表本人立场,若侵犯您的权益,请联系我们第一时间删除,谢谢!如若转载,请注明出处:http://www.bullgains.com/xgtj/3ba70e5be793b74248cb56da.html

标签:

标签: