1. 首页
  2. 股市资讯

「通达信」ZIG幅度转向指标公式

DRAWGBK(O>C,rgb(1,0,0),RGB(1,0,0),0,背景图,0);
倍数:=3;
幅度:=abs(close-REF(CLOSE,1))/REF(CLOSE,1)*100;
均幅:sum(幅度,0)/SUM(1,0)*倍数,NODRAW;
A:=H=ZIG(1,均幅) AND ZIG(1,均幅)>REF(zig(1,均幅),1);
B:=H=ZIG(1,均幅) AND ZIG(1,均幅)DRAWline(A,H,B,L,0),COLORWHITE;
DRAWLINE(B,L,A,H,0),COLORWHITE;
波段线:=ZIG(1,均幅);
涨数:BARSLASTCOUNT(波段线>REF(波段线,1)),NODRAW;
VAR1:=(C-REF(C,涨数))/REF(C,涨数)*100;
涨幅:IF(涨数>0,VAR1, DRAWNULL),NODRAW;
跌数:BARSLAstCOUNT(波段线VAr2:=(C-REF(C,跌数))/REF(C,跌数)*100;
跌幅:IF(跌数>0,VAR2, DRAWNULL),NODRAW;
股本:=(FINANCE(7)/100);
涨换手:IF(涨数>0,SUM(VOL/股本*100,涨数 1),DRAWNULL),NODRAW;
跌换手:IF(跌数>0,SUM(VOL/股本*100,跌数 1),DRAWNULL),NODRAW;

本文内容来自互联网转载,不代表本人立场,若侵犯您的权益,请联系我们第一时间删除,谢谢!如若转载,请注明出处:http://www.bullgains.com/zixun/e3fcc8024b0be673a4dc5f6f.html